Results 1 to 5 of 5

Thread: 1990 Jeep Cherokee problem(s)?????

  1. #1

    Default 1990 Jeep Cherokee problem(s)?????

    My little bro just got another car and gave me his jeep if I could get it running and I did. It was parked in front of the garage for a month and wouldnít start so when he gave me the ok I can have it, I jumped on this site and started searching for information what could be the problem and I read that the CPS is a common problem on these vehicles.
    I popped the hood and located the CPS, unplugged the connecters and blew air into to connecters with an air duster and the car fired right up. I've been driving it for a week and the last two days while driving it just cut off. The first time it happened I had the air on, it started right back up, the second day I didnít have the air on but I had been driving for a long period.

    It took about 5 cranks for it to start back up, and then I went to the shop, told them what I think and left it with them. they called me and said the car runs fine (they did a Diagnostics test supposedly) its just needs a new O2 sensor, I asked whatís the problem with it cutting off and they said they donít know it didnít do it with them and if I replace the CPS its going to be a waste of money because its not that. I have a gut feeling that if I replace the CPS I wonít have the cutting off problem but I donít know. Anybody else been through this with there jeep.

    Itís a 1990 V6 4.0 4x4 with 220,000mi the engine was rebuilt at 200,000mi two years ago

  2. #2
    Registered Blaine B.'s Avatar
    Join Date
    Nov 2005
    Location
    Northwest Indiana
    Posts
    1,876

    Default

    I have my old CPS (Replaced it and it wasn't the problem) on my 95 Cherokee. Let me know if you want it, full moneyback guarantee so you can't go wrong I guess.....it's 70.00 at Autozone and 58.00 at Advance auto. I bought a new one for 70.00 and couldn't take it back.....so I have the old sitting around.

  3. #3

    Default

    Thats the thing, I dont want to replace it if its not the problem...Thanks for letting me know about the extra CPS you have, I'll let you know if I plan to go that route.

    Blaine B., What was the problem with your jeep that you thought you needed a new CPS?

  4. #4
    Registered Blaine B.'s Avatar
    Join Date
    Nov 2005
    Location
    Northwest Indiana
    Posts
    1,876

    Default

    It wasn't starting. I replaced the CPS, and no, it still didn't start. Replaced the pickup coil (below the distributor cap......some call it the cam sensor, but all of the stores around here call it the pickup coil)

    After replacing that it fired right up. That was only 38.00 or so for the pickup coil/cam sensor (call it what you like hehe)

  5. #5

    Default

    Hey thanks for that info. I'm thinking about changing all the sensors starting with that one because the guy at the shop mentioned the cam sensor but I didnt really hear him to clearly with his broken english and all ,but he did say something about that. Today when I get off I'm going to call my moble mechanic guy to come check it out, he's always busy and couldnt help me all weekend.

    is there like a write up or guide on testing the Cam Sensor and Crank Position Sensor..I'll start with those two since thats what I keep hearing about.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Jeep Parts | Jeep Accessories | Trektop NX | Jeep Seat Covers | Jeep Wrangler | Jeep Wrangler Parts | Jeep Wrangler Accessories | Bestop | Jeep Tires | Jeep Stuff | Jeep Wrangler Tires | Jeep Wheels