Page 2 of 2 FirstFirst 1 2
Results 21 to 27 of 27

Thread: Air conditioner mildew smell

  1. #21
    Registered Blaine B.'s Avatar
    Join Date
    Nov 2005
    Location
    Northwest Indiana
    Posts
    1,876

    Default

    Top of the transmission, that would be the transmission vent.....

  2. #22

    Default

    Well, the stinky air conditioner problem grew worse through the summer months...

    Finally, I got some BG Frigi-fresh aerosol and sprayed it into the system. Car dealers carry it, Zeibart will apply it to your car for $59.95 and you can find it on eBay for around $10-20. It seems to work pretty well -- so far.

    I also removed the cabin air filter. My theory is that it traps moisture in the system and keeps it from evaporating. (It also cuts the air flow a lot).

    We'll see.

  3. #23
    Registered Blaine B.'s Avatar
    Join Date
    Nov 2005
    Location
    Northwest Indiana
    Posts
    1,876

    Default

    In my Mom's Camry, there is a rubber gasket running the entire engine hood. Right behind it (where leaves get trapped, etc) is the intake for the A/C outside air intake. We stuck some of that tube-foam type stuff into the rear engine gasket, because since the coolant overflow tank leaked out the top, that it was contributing to the smell in the vehicle. It helped some, but still continued to smell.

    However this summer, it really didn't smell. I don't know why it didn't smell this summer.

    By the way, Toyota said the leaky "gasket" at the top of the overflow coolant tank is "normal". We made another gasket for it and I ziptied it down so it is as tight as it can be against the tank. Seems to work ok!

  4. #24
    Registered
    Join Date
    Feb 2005
    Location
    Central Coast, California
    Posts
    78

    Default

    I was experiencing the mildew smell and took it to the dealer to correct. After picking up the WK my wife complained of the smell more than before taking it in; it was really affecting her sinuses. We went back to the service dept and asked if they performed the TSB (I hadn't specifically requested that initially). The service mgr checked the records and found that the TSB was followed. In addition, however, the service tech also sprayed some "deodorizer" into the vents. Supposedly the spray should clear within a couple weeks. It's been about six weeks now and the smell is still strong.
    2005 Lt. Khaki GC Ltd w/ HEMI, Nav & DVD

  5. #25
    Registered Blaine B.'s Avatar
    Join Date
    Nov 2005
    Location
    Northwest Indiana
    Posts
    1,876

    Default

    At least they did something, the Toyota dealer said "they couldn't smell it" and stated it was "perfectly fine" like every other issue that we brought to them about the Camry.

  6. #26
    Registered Yamsi401's Avatar
    Join Date
    May 2005
    Location
    Abilene Texas
    Posts
    571

    Default

    Quote Originally Posted by mon2rey View Post
    I was experiencing the mildew smell and took it to the dealer to correct. After picking up the WK my wife complained of the smell more than before taking it in; it was really affecting her sinuses. We went back to the service dept and asked if they performed the TSB (I hadn't specifically requested that initially). The service mgr checked the records and found that the TSB was followed. In addition, however, the service tech also sprayed some "deodorizer" into the vents. Supposedly the spray should clear within a couple weeks. It's been about six weeks now and the smell is still strong.
    So what is the resolution? My wife enjoys her WK Limited except for the odor. The TSB has been applied twice and once the fungicide (or whatever a mildew remover is called) wears off the odor comes back and is strong. Our WK is 15 months old, but was built in January 2005, and has 23K miles.
    Steve
    Abilene Texas
    "My JEEP ain't no SUV and your SUV ain't no JEEP!!"

    22+ years in a JEEP
    '84 XJ Cherokee Chief 2.5 I4 (traded for the '86)
    '86 XJ Pioneer 2.8 V6 (#2 Son's twice fully submerged and still runs)
    '97 ZJ Laredo 4.0 I6(#3 Son's)
    '01 WJ Limited 4.7 V8 (traded for the '04)
    '03 WJ Laredo 4.0 I6(traded for the '05)
    '04 WJ Overland 4.7 HO V8 (traded for a '06 Chevy 2500 Duramax 4x4)
    '05 WK Limited 5.7 HEMI (my lovely wife's) every option minus the navigation

  7. #27
    Registered Yamsi401's Avatar
    Join Date
    May 2005
    Location
    Abilene Texas
    Posts
    571

    Default

    Update - we're getting our air conditioner condenser replaced on next week to correct the odor problem. If all goes well I'll post and y'all can then go and get ours corrected as well!!!
    Steve
    Abilene Texas
    "My JEEP ain't no SUV and your SUV ain't no JEEP!!"

    22+ years in a JEEP
    '84 XJ Cherokee Chief 2.5 I4 (traded for the '86)
    '86 XJ Pioneer 2.8 V6 (#2 Son's twice fully submerged and still runs)
    '97 ZJ Laredo 4.0 I6(#3 Son's)
    '01 WJ Limited 4.7 V8 (traded for the '04)
    '03 WJ Laredo 4.0 I6(traded for the '05)
    '04 WJ Overland 4.7 HO V8 (traded for a '06 Chevy 2500 Duramax 4x4)
    '05 WK Limited 5.7 HEMI (my lovely wife's) every option minus the navigation

Page 2 of 2 FirstFirst 1 2

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Jeep Parts | Jeep Accessories | Trektop NX | Jeep Seat Covers | Jeep Wrangler | Jeep Wrangler Parts | Jeep Wrangler Accessories | Bestop | Jeep Tires | Jeep Stuff | Jeep Wrangler Tires | Jeep Wheels