Results 1 to 10 of 10

Thread: Jeep 304 to 360 engine swap...engine won't fire

  1. #1
    Registered hodie7's Avatar
    Join Date
    Jul 2001
    Location
    Greensboro, NC
    Posts
    565

    Default Jeep 304 to 360 engine swap...engine won't fire

    I recently swapped in a AMC 360 into my jeep it used to have an AMC 304. The engine will turn over but won't start. There is power to the coil but it won't fire. I'm getting gas but no spark. I have the 304 ignition module in there now. Do I need to install the ignition module from the 360 engine? Just wondering if they are the same on these engines.

    Hodie
    96 ZJ 4.5" RE lift 31's
    91 YJ CJ SOA LS 5.3 one tons 4.56's locked

  2. #2
    JKer with CJ/FSJ blood Ken Gaines's Avatar
    Join Date
    Aug 2002
    Location
    Shreveport, LA
    Posts
    4,967

    Default

    The ignition module should work if it is still operational. They are the same module. Check the resistance across the purple and orange wires coming off the distributor pickup plug. The resistance should be 400 to 800 ohms. If it is out of that range, try replacing it and see if that helps. You could also just pull the dizzy out of the 304 and put it in the 360.
    Originally stated by Mr.George Carlin -=-
    You know what's the best thing about living on the edge of the water? You only have * * * * * * *s living on three sides of you. If they come from the other side, you can hear them splashing!!!
    "Life is a journey that's measured not in miles or years, but in experiences."
    -Jimmy Buffett 1998
    "If you don't fish, you should."
    -D.A. McKee Ph.D., 2002 TAMUCC Ichthyology Class Intro Lecture (How much more wisdom could one need than this?)
    O)||||||(O
    Ken

  3. #3
    Registered
    Join Date
    Oct 2003
    Location
    Honolulu, HI
    Posts
    327

    Default

    also make sure that the distributor isn't 180* off...ask me if I've done this recently And if you're thinking of changing the Ignition Module, I'd go with an HEI upgrade...just my .02

  4. #4
    Registered hodie7's Avatar
    Join Date
    Jul 2001
    Location
    Greensboro, NC
    Posts
    565

    Default

    I'll try switching out the ignition module since I have one that came with the 360. Maybe my old one was fried. I'll check to see if my dist cap is 180 off too but I wasn't getting spark at the plugs.
    96 ZJ 4.5" RE lift 31's
    91 YJ CJ SOA LS 5.3 one tons 4.56's locked

  5. #5
    redheaded stepchild mbalbritton's Avatar
    Join Date
    Jul 2001
    Location
    Somewhere other than here
    Posts
    3,631

    Default

    Noah, run through what is happening


    you turn the key and it turns and turns, but you never get a fire? you get one or two little fires? you get eratic fires?

    are your plugs soaking wet? have you checked for spark at the plugs?

    have you checked and double checked your firing order and timing?

    brent
    "Ya, you can put a chevy engine in a jeep, but it's kinda like taking your sister to the prom. It'll work but it won't put out."


  6. #6
    Registered hodie7's Avatar
    Join Date
    Jul 2001
    Location
    Greensboro, NC
    Posts
    565

    Default

    It never fires. The plugs are new. I'm not getting spark at the plugs. The starter just turns the engine.
    96 ZJ 4.5" RE lift 31's
    91 YJ CJ SOA LS 5.3 one tons 4.56's locked

  7. #7
    JKer with CJ/FSJ blood Ken Gaines's Avatar
    Join Date
    Aug 2002
    Location
    Shreveport, LA
    Posts
    4,967

    Default

    Is the distributor turning?
    Originally stated by Mr.George Carlin -=-
    You know what's the best thing about living on the edge of the water? You only have * * * * * * *s living on three sides of you. If they come from the other side, you can hear them splashing!!!
    "Life is a journey that's measured not in miles or years, but in experiences."
    -Jimmy Buffett 1998
    "If you don't fish, you should."
    -D.A. McKee Ph.D., 2002 TAMUCC Ichthyology Class Intro Lecture (How much more wisdom could one need than this?)
    O)||||||(O
    Ken

  8. #8
    Registered jeepsr4ever's Avatar
    Join Date
    Oct 2003
    Location
    MN.....muddy MN LOL!!
    Posts
    614

    Default

    Your purple wire form the ignition control module will give the dizzy its spark..check to make sure it is hooked up and hot

    100+ jeeps

  9. #9
    Registered
    Join Date
    Jun 2003
    Location
    Maryland
    Posts
    357

    Default

    Do you have a good ground from your engine to the frame?

  10. #10
    Registered hodie7's Avatar
    Join Date
    Jul 2001
    Location
    Greensboro, NC
    Posts
    565

    Default

    I'll have to check those things guys. Thanks for the suggestions.

    I think the engine is ground to the top plate of the york compressor to the body.

    Hodie
    96 ZJ 4.5" RE lift 31's
    91 YJ CJ SOA LS 5.3 one tons 4.56's locked

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Jeep Parts | Jeep Accessories | Trektop NX | Jeep Seat Covers | Jeep Wrangler | Jeep Wrangler Parts | Jeep Wrangler Accessories | Bestop | Jeep Tires | Jeep Stuff | Jeep Wrangler Tires | Jeep Wheels